+ Rispondi alla Discussione
Risultati da 1 a 15 di 15

Joomla: ogni 2 anni si ricomincia da capo

Ultimo Messaggio di FDA il:
  1. #1
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64

    Joomla: ogni 2 anni si ricomincia da capo

    A ogni nuova grossa versione, joomla non è più compatibile con la precedente, sopratutto avendo un sito multilingue.
    questo diventa un grosso problema avendo 1000 pagine di sito. Come risolvere il problema? siccome adesso esce joomla 3.5 naturalmente non compatibile, il multilingue è gia integrato quindi niente più fish per le traduzioni, le 1000 pagine mi sembra di aver capito che me le devo copiare a mano dopo aver ricreato la struttura! lavoro allucinante!
    Qualcuno ha un idea come fare? devo veramente importare 1000 pagine a mano?
    se rifaccio il sito con wordpress, in futuro avrò lo stesso problema?
    Correzione dell'Atlante, la chiave della tua salute

  2. #2
    User Attivo
    Data Registrazione
    Mar 2009
    Località
    Milano
    Messaggi
    2,172
    Segui ziobudda su Twitter Aggiungi ziobudda su Google+
    Ciao, secondo me stai sbagliando visione. qualsiasi cms ha nelle major release una incompatibilità con le precedenti. E' il costo della evoluzione.

    con wp avrai lo stesso problema. Ed anche con drupal.

    M.

  3. #3
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64
    ma chi ha siti da 10.000 pagine come fa? ogni 2 anni copia 10.000 pagine?
    Correzione dell'Atlante, la chiave della tua salute

  4. #4
    User Attivo
    Data Registrazione
    Mar 2009
    Località
    Milano
    Messaggi
    2,172
    Segui ziobudda su Twitter Aggiungi ziobudda su Google+
    Non si corre dietro all'ultima versione. Mai. Specialmente per siti di un certo livello.

    M.
    Sviluppo creazione siti portali Drupal - - Assistenza Drupal - Corsi Drupal

  5. #5
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64
    il problema è che il provider vuole disattivare il sito perche dice che versioni vecchie sono a rischio.
    Correzione dell'Atlante, la chiave della tua salute

  6. #6
    User
    Data Registrazione
    Dec 2012
    Località
    Milano
    Messaggi
    64
    Ciao atlantotec,
    quale versione Joomla stai utilizzando?
    Se stai usando Joomla 2.5, al momento disponibile alla versione 2.5.8, non credo tu debba preoccuparti in quanto sarà supportata fino al 2014.
    La nuova release, Joomla 3, è al momento stabile ma fortemente sconsigliata per siti in produzione quindi se ne riparlerà tra almeno un paio d'anni.
    Questo per dirti che nel momento in cui scegli un CMS, qualsiasi esso sia, devi per forza di cose, come ti ha detto anche ziobudda, seguire il suo sviluppo ed evoluzione, per esempio contattando i produttori di estensioni che stai utilizzando e chiedendo informazioni su eventuali aggiornamenti eccetera.

    Sul discorso che il provider vuole disattivarti il sito mi pare molto improbabile, a meno che tanto per farti un esempio tu stia utilizzando Joomla 1.5 mai aggiornata.

    Al momento la mgliore versione è appunto la 2.5, costantemente aggiornata per quanto riguarda la sicurezza, supportata per almeno un paio d'anni ancora e con la maggior parte di estensioni compatibili. Hai un po' di tempo per iniziare a testare la nuova versione e provare per esempio la fase di migrazione dalla 2.5 alla 3, tra l'altro operazione molto semplice da eseguire, a parte naturalmente l'eventuale incompatibilità con le estensioni installate.

  7. #7
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64
    uso l'ultima versione di 1.5
    Correzione dell'Atlante, la chiave della tua salute

  8. #8
    User
    Data Registrazione
    Dec 2012
    Località
    Milano
    Messaggi
    64
    Joomla 1.5 purtroppo è fuori produzione da aprile dello scorso anno, quindi non è più supportata soprattutto per quello che riguarda la sicurezza. Da questo punto di vista il tuo provider potrebbe aver ragione.
    Tieni presente comunque che prima di essere "abbandonata" come versione sono passati circa 3 anni.

  9. #9
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64
    quindi come faccio trasferire 1000 pagine?
    Correzione dell'Atlante, la chiave della tua salute

  10. #10
    User
    Data Registrazione
    Dec 2012
    Località
    Milano
    Messaggi
    64
    Personalmente mi riesce difficile darti un consiglio valido in quanto della tua installazione non so proprio nulla, se è aggiornata all'ultima versione, che template utilizzi, quali estensioni eccetera. Magari altri utenti più preparati di me potranno darti qualche indicazione.

    Al momento posso solo indicarti quella che è la strada che seguirei io, ovvero prima di tutto accertati di avere tutto aggiornato, database ottimizzato, una verifica completa insomma che confermi il regolare funzionamento di tutta la struttura.
    Successivamente trasporta tutto il sito nel tuo computer, stessa cosa per il database. In questo modo puoi far girare in un server locale la tua struttura.
    A questo punto puoi iniziare a testare la procedura di migrazione dalla 1.5 alla 2.5, per approfondire devi leggere questa guida ufficiale: joomla.it/mediawiki/index.php/Joomla!_2.5:Migrare_da_Joomla_1.5_a_Joomla_2.5

    Fondamentale per la buona riuscita della migrazione è verificare che tutte le estensioni che utilizzi siano disponibili anche per la versione 2.5

    Ho migrato diversi siti dalla 1.5 alla 2.5 senza particolari problemi, se non appunto la "scocciatura" del lavoro, al punto che mi rendevo conto ogni volta che avrei anche potuto evitare i test in locale, cosa che però ti sconsiglio, è sempre meglio sperimentare su una copia che sul sito vero e proprio.

    Inizia a studiarti la guida che ti ho linkato, poi un po' alla volta procedi con i vari test.

  11. #11
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64
    Grazie della tua risposta.
    Con fish cosa succede? la nuova versione gestisce le traduzioni in modo differente da quanto ho capito...
    Correzione dell'Atlante, la chiave della tua salute

  12. #12
    User
    Data Registrazione
    Dec 2012
    Località
    Milano
    Messaggi
    64
    Mi dispiace ma non ne ho idea.

    Scusa se mi permetto di farti un'osservazione, mi auguro costruttiva per te, ma credo che tu stia commettendo un errore a proseguire in questa discussione, il titolo stesso e la stanza in cui hai postato offrono sicuramente spunti di discussione ma che difficilmente possono aiutarti, in concreto, a risolvere i tuoi problemi.
    Fai mente locale su quali sono le cose su cui ritieni di aver bisogno di una mano o qualche indicazione approfondita e apri una discussione specifica a quello che chiedi, in questo modo aumenti le possibilità che tra tanti utenti preparati tu possa trovare aiuto o comprendere meglio alcuni meccanismi.

  13. #13
    User L'avatar di atlantotec.it
    Data Registrazione
    Mar 2008
    Messaggi
    64
    grazie del consiglio
    Correzione dell'Atlante, la chiave della tua salute

  14. #14
    User
    Data Registrazione
    Jan 2010
    Messaggi
    49
    Il fatto che ogni paio d'anni bisogna aggiornare il Cms è una scocciatura. Però a quanto sembra anche wp e Drupal soffrono dello steso "problema".

    Comunque se uno fa un sito ad un cliente che gli dice? Che è a scadenza?

  15. #15
    FDA
    FDA è offline
    Moderatore L'avatar di FDA
    Data Registrazione
    Sep 2012
    Località
    Napoli
    Messaggi
    1,908
    Segui FDA su Twitter Aggiungi FDA su Google+ Aggiungi FDA su Facebook
    Ciao Atlantotec.
    Come facevano notare egotheme e ziobudda, la 1.5 di Joomla ha qualche anno (credo sia del 2008) e in ogni caso un sito di una certa complessità deve avere un orizzonte di alcuni anni prima di essere oggetto di una migrazione.
    Nel caso di specie, però, la migrazione da 1.5 a 2.5 non è affatto impossibile, neanche in presenza di estensioni quali JoomFish. E' vero, dalla 1.6 sono cambiate molte cose e le lingue nella 2.5 sono gestite diversamente, ma è sempre possibile migrare. Per la migrazione da Joomla 1.5 + JoomFish a Joomla 2.5 valuta Josetta. Ecco una paio di link, ma puoi eseguire una ricerca su Google per trovare ulteriore supporto:

    - http: // extensions. joomla. org / extensions/languages/multi-lingual-content/20136
    - http: // www . enthous. it / joomla/migrare-da-joomla-15-joomfish-con-josetta-a-joomla-25 .html

    Potresti avere qualche noia legata a particolari formattazioni, peculiarità del template grafico, estensioni non più supportate nella 2.5. Si tratta comunque di problemi superabili con un po' di lavoro.
    Il mio consiglio è di chiedere un po' di tempo al provider e intanto lavorare alla migrazione su una copia. Se il provider non vuole attendere cercane un altro che abbia un minimo di pazienza. Con il passaggio a 2.5.x guadagnerai almeno 18 mesi, non è poco.
    Buon lavoro.
    Francesco

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.