+ Rispondi alla Discussione
Risultati da 1 a 3 di 3

Capricci del flash con i comandi loadmovie e loadmovienum

Ultimo Messaggio di Bombardier il:
  1. #1
    User Newbie
    Data Registrazione
    Jul 2014
    Località
    Napoli
    Messaggi
    2

    Capricci del flash con i comandi loadmovie e loadmovienum

    Buona sera a tutti.
    Ho fatto una ricerca per evitare di creare un nuovo thread ma purtroppo senza successo.
    Il mio problema è il seguente:
    Sto cercando di realizzare un sito web in flash con actionscript 2.0 e ho un problema nel caricare sfw esterni delle varie pagine nell' Swf principale.
    A parole sarebbe semplice io ho un swf dove si compone la barra di navigazione senza sfondo e all'ultimo fotogramma viene richiamato un swf esterno contenente uno sfondo e una finestra con all'interno un testo di presentazione.
    Ad ogni tasto l'swf principale rimane li dov'è mentre gli swf esterni contenenti le altre pagine si caricano e si scaricano a seconda della pagina selezionata.
    In pratica usando il comando loadmovie viene caricato un swf esterno che però sostituisce il precedente ( il principale contenente la barra di navigazione ). Risultato: sparisce la barra di navigazione e compare solo il contenuto dell'swf esterno ovvero lo sfondo e la finestra con testo.
    Ho usato il comando loadmovienum e l'swf viene caricato ma con lo stesso risultato.
    Seguendo alcune guide ho inserito un livello contenente una movieclip vuota a cui ho dato nome "contenitore" alchè ho inserito il comando
    loadmovienum ("nomefile.swf", 'contenitore' ) risultato: al caricamento dell'Swf viene aperta una pagina web con l'swf esterno.
    E' ovvio che sto sbagliando qualcosa ma non riesco a capire cosa. Ho usato tutte le varianti dei parametri che ho a disposizione ovvero il la specifica del numero di livello dove caricare l'swf esterno, la movieclip vuota, la voce _root.contenitore ma non cambia nulla.
    Qualcuno potrebbe aiutarmi ??? Vi ringrazio anticipatamente.
    Buona serata.

  2. #2
    User
    Data Registrazione
    May 2008
    Località
    Olbia
    Messaggi
    2,762
    As2? Bisogna che me lo ripassi, la soluzione con il contenitore è buona, al posto di loadmovienum usa il comando loadmovie

  3. #3
    User Newbie
    Data Registrazione
    Jul 2014
    Località
    Napoli
    Messaggi
    2
    Buonasera e grazie per la risposta. Credo che tra le svariate prove che ho fatto abbia provato anche con il loadmovie e il contenitore ma sarò più sicuro quando avrò provato stasera.

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.