Giorgiotave.it

Condividiamo idee e conoscenza dal 2003...
...dopo 17 anni una Nuova Storia sta per nascere
Scopri di più
+ Rispondi alla Discussione
Risultati da 1 a 3 di 3

Default problema maschera da libreria (flash cs3 as2)

Ultimo Messaggio di raatslab il:
  1. #1
    User
    Data Registrazione
    Dec 2006
    Messaggi
    39

    Default problema maschera da libreria (flash cs3 as2)

    eccomi nuovamente quà, per chiedere un aiuto, vi espongo la situazione:
    scena contatti
    ho lo stage, sullo stage ho un mc chiamato formmail_mc,(il quale con una serie di tween forma il form per la mail), sopra il livello del formmail_mc ho il livello che si chiama email mask,nel fotogramma uno gli ho dato questo codice

    this.attachMovie("emailmask_mc","maschera",this.ge tNextHighestDepth(20),{_x:470, _y:96});
    this.formmail_mc.setMask(maschera);

    adesso vorrei che con l'ultima tween del formmail_mc, la maschera sparisse, perchè alla prima esecuzione va tutto, ma se vado in un'altra pagina con il menu, mi ritrovo la maschera in tutte le pagine. spero di essere stato chiarao, comunque spiegherò per filo e per segno se qualcuno mi darà una mano.

    allego il file dattegli un occhio
    Ciao
    File Allegati File Allegati

  2. #2
    Esperta L'avatar di Onsitus
    Data Registrazione
    Oct 2006
    Località
    RM
    Messaggi
    3,083
    Perche complicarti la vita con setMask e non inserire diretamente un livello maschera in emailsender_mc

  3. #3
    User
    Data Registrazione
    Dec 2006
    Messaggi
    39
    Citazione Originariamente Scritto da Onsitus Visualizza Messaggio
    Perche complicarti la vita con setMask e non inserire diretamente un livello maschera in emailsender_mc


    perchè poi non funzionano le textbox se metto una maschera sopra, comunque ho risolto Onsitus, bastava inserire questo codice nei pulsanti
    on (release) {
    formmail_mc.setMask(null)
    removeMovieClip(this._parent["maschera"])
    _root.gotoAndStop("home");
    }
    invece ho un problema in firefox, che quando inserisco la @ nel campo email non me la scrive, è come se la tastiera diventasse usa, problema che non riscontro su IE... cosa può essere.

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.