+ Rispondi alla Discussione
Risultati da 1 a 12 di 12

OVH VPS CLassic 4: aggiornamento Plesk e PHP

Ultimo Messaggio di strizzanespole il:
  1. #1
    User
    Data Registrazione
    May 2008
    Messaggi
    78

    OVH VPS CLassic 4: aggiornamento Plesk e PHP

    Ho una VPS LINUX su OVH e dovrei aggiornare sia il Plesk sia la versione del PHP , qualcuno puo' indicarmi una guida dettagliata per farlo. Ho contattato l'assitenza ma come temevo hanno rimandato al mittente la domanda...

  2. #2
    Moderatore L'avatar di paolino
    Data Registrazione
    Apr 2005
    Località
    San Cipriano Beach
    Messaggi
    5,058
    Distribuzione in uso?

  3. #3
    User
    Data Registrazione
    May 2008
    Messaggi
    78
    SO Centos 6.5
    Plesk: 11.5.30

  4. #4
    Moderatore L'avatar di paolino
    Data Registrazione
    Apr 2005
    Località
    San Cipriano Beach
    Messaggi
    5,058
    comando

    Codice:
    yum update
    per aggiornare PHP e gli altri pacchetti della distribuzione. Ovviamente aggiorna all'ultima versione di PHP presente nei repository CentOS. Aggiornare manualmente all'ultima versione disponibile sul sito php.net è estremamente rischioso se non si ha dimestichezza con i sistemi Linux.

    Plesk invece si aggiorna direttamente dal suo pannello di controllo, come spiegato qui http://download1.parallels.com/Plesk...gration-guide/

  5. #5
    User
    Data Registrazione
    May 2008
    Messaggi
    78
    Grazie per i consigli, in pratica ho questa VPS da un annetto e mi hanno consigliato di fare gli aggiornamenti, il problema è che non masticando benissimo la materia VPS tranne per qualche operazione via plesk e qualche comando SSH, ho timore di far danni. Mi hanno consigliato di aggiornare anche il Sistema Operativo, per poi passare all'aggiornamento del Plesk, della versione PHP. Non vorrei addentrarmi in un campo minato pero', specialmente per quanto riguarda l'aggiornamento del sistema operativo. Per gli altri due: Plesk ho visto che si dovrebbe riuscir a farlo direttamente dal Plesk attuale, PHP provo a seguire i tuoi consigli. Rsta l'incognita del Sistema Operativo...

  6. #6
    Moderatore L'avatar di paolino
    Data Registrazione
    Apr 2005
    Località
    San Cipriano Beach
    Messaggi
    5,058
    Aggiornare il sistema operativo? Puoi fare solamente in 2 modi senza pagarla cara:

    1. lo fa chi ha accesso fisico al sistema host sul server ( OVH )
    2. hai un KVM

    In caso contrario dovresti fare un upgrade di versione, ma è un'operazione estremamente rischiosa e mai va fatto su un server in produzione senza aver prima testato il tutto su qualche altro computer.

  7. #7
    User
    Data Registrazione
    May 2008
    Messaggi
    78
    Si, accedendo al control panel di OVH ho la possibilità di utilizzare KVM.
    Comunque approfitto della tua disponibilità per chiederti se al momento mi è sufficiente aggiornare solo la versione del Plesk e del PHP (attualmente c'è la 5.3.3) , senza il Sistema Operativo, operazione, quest'ultima che mi sembra più complicata.
    Per il resto invece:
    1) Plesk ho visto che posso aggiornarlo seguendo la procedura di aggiornamento che trovo nel Plesk attuale,
    2) per il PHP posso utilizzare il tuo consiglio "yum update" per aggiornarlo alla versione più recente?

    Ho un'ulteriore domanda, analizzando il server tramite Plesk ho notato che l'utilizzo della memoria Swap risulta utilizzata al 99%. Mi conviene intervenire e aumentare lo spazio dello Swap, se si, come posso farlo?



  8. #8
    Moderatore L'avatar di paolino
    Data Registrazione
    Apr 2005
    Località
    San Cipriano Beach
    Messaggi
    5,058
    Citazione Originariamente Scritto da zklid Visualizza Messaggio
    Comunque approfitto della tua disponibilità per chiederti se al momento mi è sufficiente aggiornare solo la versione del Plesk e del PHP (attualmente c'è la 5.3.3) , senza il Sistema Operativo, operazione, quest'ultima che mi sembra più complicata.
    Direi di si. A che pro aggiornare il sistema operativo se è ancora supportato a livello di bugfix. Altro discorso invece se il periodo di supporto è terminato e quindi il server potrebbe avere vulnerabilità software non patchate.

    Citazione Originariamente Scritto da zklid Visualizza Messaggio
    2) per il PHP posso utilizzare il tuo consiglio "[COLOR=#333333]yum update" per aggiornarlo alla versione più recente?
    Lo strumento di default è yum. Procedere manualmente è il metodo più rapido per creare problemi, a volte molto difficili da risolvere.

    Citazione Originariamente Scritto da zklid Visualizza Messaggio
    Ho un'ulteriore domanda, analizzando il server tramite Plesk ho notato che l'utilizzo della memoria Swap risulta utilizzata al 99%. Mi conviene intervenire e aumentare lo spazio dello Swap, se si, come posso farlo?
    Bisogna vedere se la ram è altrettanto satura. Nel qual caso si può aumentare lo swap, ma bisogna intervenire sui volumi LVM. Se ricordo bene non è possibile farlo da Plesk.

  9. #9
    User
    Data Registrazione
    May 2008
    Messaggi
    78
    Ciao, allora, ho aggiornato il Plesk alla versione 12.5.30 e in questa versione è possibile anche selezionare la versione PHP da utilizzare, cosa che ho fatto, passando dalla 5.3.3 alla 5.4. Sembrava tutto ok, ma sull'home del Plesk ottengo questo messaggio di errore, sto cercando la soluzione, ma ancora non ne sono venuto a capo...

    I nuovi file di configurazione per il server web Apache non sono stati creati a causa di errori nei modelli di configurazione: nginx: [emerg] "proxy_read_timeout" directive is duplicate in /var/www/vhosts/system/ghz-service.it/conf/vhost_nginx.conf:3 nginx: configuration file /etc/nginx/nginx.conf test failed . Le descrizioni di errore dettagliate ti sono state inviate per posta elettronica. Correggi gli errori e fai clic su "qui" per generare i file di configurazione danneggiati nuovamente o su "qui" per generare tutti i file di configurazione.

  10. #10
    Moderatore L'avatar di paolino
    Data Registrazione
    Apr 2005
    Località
    San Cipriano Beach
    Messaggi
    5,058
    Boh, non saprei. Lì dice che ha cercato di configurare Apache ma in realtà il web server è Nginx.

  11. #11
    User
    Data Registrazione
    May 2008
    Messaggi
    78
    Ciao, ho risolto anche quel problema, era dovuto a delle vecchie impostazioni personali nel pannello ngix .
    Mi resta un ultimo problema:
    nella nuova versione del Plesk c'è un servizio di monitoraggio del server, spesso mi notifica problemi con la memoria swap, il cui utilizzo supera il 90% (nonostante l'utilizzo della memoria della vps sia introrno al 10% ??). Forse devo aumentare la memoria swap?
    Ultima modifica di zklid; 10-02-16 alle 18:48

  12. #12
    User
    Data Registrazione
    Feb 2016
    Località
    Moon
    Messaggi
    14
    nginx non è un pannello

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.