+ Rispondi alla Discussione
Risultati da 1 a 3 di 3

Server VPS: solo Mail di OS X non riesce a scaricare/inviare

Ultimo Messaggio di dapinna il:
  1. #1
    User
    Data Registrazione
    Oct 2006
    Messaggi
    15

    Server VPS: solo Mail di OS X non riesce a scaricare/inviare

    Salve a tutti :-)

    Spero di non essere OT

    Ho un server VPS su cui sono ospitati i domini di diversi miei clienti.
    Tutto funziona bene, ma dato che con alcune configurazione di Client e/o App di Posta ci sono dei problemi con i certificati autoemessi e che i clienti ovviamente non vogliono acquistare il certificato whildcart (qualcuno è svenuto quando ho detto quanto costava ) ho trovato una soluzione.

    Ho ottenuto un certificato Let's Encrypt per il server vps, mioaccount.nomeserver.tld e ho sostituito il classico nome host per imap e smtp (es. imap.nomedominio.tld) con mioaccount.nomeserver.tld.
    Ho fatto una prima prova con Thunderbird, poi con l'App Gmail di Android e tutto filava liscio. Ho esteso la prova ad alcuni clienti con MS Outlook, tutto OK (sparito il classico avviso di certificato non valido ad ogni avvio) e anche su iOS tutto OK, la configurazione è risultata veloce.

    Tutto OK con tutti i clienti, tranne con una che usa "OS X El Captain" e il programma "Mail" che non vuole digerire quel nome host, facendo risultare imap e smtp come se fossero "off line", anche togliendo le impostazioni SSL.
    Ho provato persino io in Teleassistenza senza risolvere. Ho persino reinserito i vecchi nome host, legati al dominio... ma nulla.
    Quindi non è un problema di parametri capiti/inserti male dalla cliente o impostazioni sbagliate... oppure c'è qualche impostazione strana di OS X/Mail che non conosco.

    Ho un paio di altri clienti con OS X, non so qualche versione, che però non hanno avuto problemi con la configurazione della posta (ma non so se usano Mail o altri client di posta).

    La mia domanda è:
    Occorre fare qualche impostazione particolare sul server per renderlo compatibile con Mail/OS X?
    Oppure occorre fare una impostazione particolare su Mail/OS X?



    Ma i Mac non dovevano essere dei "Computer" semplici e intuitivi a prova di "utonto"?





    Nel caso possa essere utile:
    I dettagli del VPS sono:
    - CentOS 6.9
    - Versione 17.5.3 Update #17
    - Server di posta installato Postfix
    - Server IMAP/POP3 installato: Dovecot

    Ringrazio Anticipatamente per le risposte

  2. #2
    Utente Premium L'avatar di valent
    Data Registrazione
    Feb 2007
    Località
    Trento
    Messaggi
    499
    Dipende da come hai configurato Dovecot e Postfix, prova a modificare nelle impostazioni dell'account di posta metti Autenticazione = password e inserisci nome utente, password.
    Il problema è in fase di invio della posta o ricezione (o ambedue)?

  3. #3
    User
    Data Registrazione
    Oct 2006
    Messaggi
    15
    Citazione Originariamente Scritto da valent Visualizza Messaggio
    Dipende da come hai configurato Dovecot e Postfix
    Ciao, e grazie per la risposta.
    Non credo di aver fatto particolari configurazioni a Dovecot e Postfix; gestisco tutto tramite Plesk, quindi forse alcune impostazioni sono raggruppate in un unica pagina di configurazione.


    , prova a modificare nelle impostazioni dell'account di posta metti Autenticazione = password e inserisci nome utente, password.
    Credo di aver fatto anche quella prova.

    Il problema è in fase di invio della posta o ricezione (o ambedue)?
    Entrambi... Il programma vede il server, sia IMAP che SMTP come Offline.
    Dato che un altro cliente con un Mac tutto funziona correttamente, non è certamente un problema di configurazione del mio server... o qualche incompatibilità con OSX

    Probabilmente quella cliente ha qualche aggiornamento mancante che causa il problema...

+ Rispondi alla Discussione

Tag per Questa Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.