+ Rispondi alla Discussione
Risultati da 1 a 6 di 6

errore visualizzazione icone lightbox su Explorer e Chrome

Ultimo Messaggio di piemusc il:
  1. #1
    User L'avatar di piemusc
    Data Registrazione
    Sep 2012
    Località
    Locri
    Messaggi
    48
    Aggiungi piemusc su Linkedin

    errore visualizzazione icone lightbox su Explorer e Chrome

    Buongiorno a tutti,
    Ho installato l'ultima versione di lightbox..Ho testato il risultato su Firefox,e funziona perfettamente,l'effetto lightbox funziona anche su Explorer e Chrome ma in questi ultimi due mi segnala errore nella visualizzazione delle icone di caricamento file (loading.gif),per la chiusura del file(close) e nei bottoni direzionali (next e prev)..Dopo aver visionato più volte il codice ho constatato che se fosse un problema di css allora anche Firefox mi sagnalerebbe errore,quindi ho escluso questa opzione,ho pensato quindi a un conflitto di script(scusate l'ignoranza)ma non riesco a trovare una soluzione..
    I commenti condizionali sarebbero una soluzione?C'è un modo per risolvere questo problema?
    p.s. AIUTATEMIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII IIIIIIII
    Buona giornata a tutti ciao

  2. #2
    Esperta L'avatar di Jantima
    Data Registrazione
    Mar 2005
    Località
    Silicon Valley
    Messaggi
    639
    Ciao, piemusc. Dipende da che versione di lightbox utilizzi e da che errore ricevi esattamente e come. Non posso aiutarti se non mi dai il link (aggiungendo spazi per modo che non sia attivo) ad una pagina di prova in cui io possa vedere l'errore che ricevi e il codice che hai.

  3. #3
    User L'avatar di piemusc
    Data Registrazione
    Sep 2012
    Località
    Locri
    Messaggi
    48
    Aggiungi piemusc su Linkedin
    Ciao Jantima e grazie per aver risposto
    Questa è la pagina del sito dove ho inserito l'effetto lightbox.. polito group.it / hardw are%20e%20 attre zzature. html
    Ho utilizzato lightbox v2.51

  4. #4
    Esperta L'avatar di Jantima
    Data Registrazione
    Mar 2005
    Località
    Silicon Valley
    Messaggi
    639
    Credo sia un problema di percorso del file immagine. Io non le vedo nemmeno su firefox. Se usi firebug oppure inspect element su firefox e guardi il percorso delle immagini, e poi lo clicchi, ti accorgerai che é sbagliato e che non trova l'immagine. (per quale motivo su alcuni browser la vedi e altri no è un discorso complesso)
    Considera che nel CSS hai: ../images/close.png
    Solo che questo percorso, viene considerato relativamente al percorso attuale della pagina web che carica il css (e non relativo a dove il file css si trova!), il che diventa ...group .it/images/close.png
    Mentre l'immagine si trova a ... group . it/lightbox2/images/close.png

    prova a cambiare nel CSS (lightbox2/css/lightbox.css) metti sia il percorso completo e assoluto, eg: w w w .polito group . it/lightbox2/images/close.png
    Oppure ./lightbox2/images/close.png (con il punto davanti)
    Oppure copia la cartella images e mettine una copia nella public_html directory principale del sito.

    La stessa cosa per tutte le altre immagini di lightbox.

    Ciao spero di essere stata d'aiuto.

  5. #5
    User L'avatar di piemusc
    Data Registrazione
    Sep 2012
    Località
    Locri
    Messaggi
    48
    Aggiungi piemusc su Linkedin
    Sei stata utilissima e molto chiara :-) grazie per tutte queste informazioni utili che sicuramente mi saranno di grande aiuto! Ciao e grazie ancora :-)

  6. #6
    User L'avatar di piemusc
    Data Registrazione
    Sep 2012
    Località
    Locri
    Messaggi
    48
    Aggiungi piemusc su Linkedin
    Problema risolto..
    Bisognava richiamare il percorso del file non con ../images/close.png ma scrivere direttamente lightbox2/images/close.png proprio xkè la cartella immagini è all'interno della cartella lightbox2 e in fine bisogna aprire il file lightbox.js e modificare ancora il percorso immagine visibile nel codice che riporto in basso:

    (function() {
    var $, Lightbox, LightboxOptions;

    $ = jQuery;

    LightboxOptions = (function() {

    function LightboxOptions() {
    this.fileLoadingImage = 'Lightbox2/images/loading.gif';
    this.fileCloseImage = 'Lightbox2/images/close.png';
    this.resizeDuration = 700;
    this.fadeDuration = 500;
    this.labelImage = "Image";
    this.labelOf = "of";
    }



    Detto Questo ringrazio ancora Jantima per il prezioso aiuto e auguro a tutti gli utenti del forum un Buon Natale e Buon 2013 ciao

+ Rispondi alla Discussione

Tag per Questa Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.