+ Rispondi alla Discussione
Risultati da 1 a 8 di 8

Ripristino sito in locale e reinderizzamento www.localhost

Ultimo Messaggio di altraSoluzione il:
  1. #1
    User
    Data Registrazione
    Jun 2017
    Località
    Pianella
    Messaggi
    15
    Aggiungi henryco.88 su Facebook Aggiungi henryco.88 su Linkedin

    Ripristino sito in locale e reinderizzamento www.localhost

    Ciao a tutti.
    Ho effettuato il ripristino in locale di un sito web in Joomla. L'operazione avviene con successo il problema è che non visualizzo correttamente il sito tranne con il browser Opera. Inoltre, nonostante io digiti nella barra degli indirizzi localhost/miosito avviene un redirect a www localhost. Perché questo redirect?

    In particolare:

    - Chrome: mi dice che la connessione non è privata;
    - Firefox: Non riesce a contattare il server www localhost
    - Opera: il frontend si vede bene (però sempre con il redirect www localhost. Se voglio accedere però all'administrator mi dice che è impossibile raggiungere il sito.


    Premetto che ho altri siti installati in locale con XAMPP che funzionano e si vedono perfettamente.

    Come posso risolvere?

  2. #2
    User L'avatar di altraSoluzione
    Data Registrazione
    Jun 2017
    Località
    Roma
    Messaggi
    42
    Segui altraSoluzione su Twitter Aggiungi altraSoluzione su Google+ Aggiungi altraSoluzione su Facebook Aggiungi altraSoluzione su Linkedin Visita il canale Youtube di altraSoluzione
    Ciao, da quel che posso capire hai impostato Joomla per fare il redirect su https ed essendo localhost privo di certificati "reali" vieni avvisato da chrome.
    Per quanto riguarda il www potrebbe essere aggiunto dal browser nel caso non riesca a trovare il server locale. Prova a forzare l'url come http : //localhost/miosito (dopo aver disattivato il redirect https).

    Potrebbero anche verificarsi dei problemi nel caso alcuni link abbiano il path assoluto (che inizia con /) perché questi cercherebbero i file in localhost/ invece di localhost/miosito

    Esistono dei metodi per fare in modo che tu possa accedere a ogni sito in xampp come se fosse in internet cioè, per esempio, miosito.localhost/ invece di localhost/miosito e in questo modo non avresti il problema del puntamento a / dopo la migrazione, ma sono configurazioni abbastanza complesse che coinvolgono sia il DNS che Apache.

  3. #3
    User
    Data Registrazione
    Jun 2017
    Località
    Pianella
    Messaggi
    15
    Aggiungi henryco.88 su Facebook Aggiungi henryco.88 su Linkedin
    io ho anche altri siti in Joomla creati in https e poi installati in locale che funzionano bene. Non capisco perchè con questo sito ho i problemi. Quindi che procedura dovrei fare per risolvere il problema?

  4. #4
    User L'avatar di altraSoluzione
    Data Registrazione
    Jun 2017
    Località
    Roma
    Messaggi
    42
    Segui altraSoluzione su Twitter Aggiungi altraSoluzione su Google+ Aggiungi altraSoluzione su Facebook Aggiungi altraSoluzione su Linkedin Visita il canale Youtube di altraSoluzione
    Nell'interfaccia admin di Joomla vai su System/Global configuration/Server e verifica che l'impostazione "
    Force HTTPS" sia impostata su "None".
    Poi prova ad accedere a http : // localhost/tuosito

  5. #5
    User
    Data Registrazione
    Jun 2017
    Località
    Pianella
    Messaggi
    15
    Aggiungi henryco.88 su Facebook Aggiungi henryco.88 su Linkedin
    Non riesco a visualizzare la pagina di login dell'administrator. Posso visualizzare solo il frontend con opera

  6. #6
    User L'avatar di altraSoluzione
    Data Registrazione
    Jun 2017
    Località
    Roma
    Messaggi
    42
    Segui altraSoluzione su Twitter Aggiungi altraSoluzione su Google+ Aggiungi altraSoluzione su Facebook Aggiungi altraSoluzione su Linkedin Visita il canale Youtube di altraSoluzione
    In che senso? Ricevi un errore o cosa? Cambiare browser aiuta?

    In alternativa puoi editare direttamente il file configuration.php? In caso affermativo di dico cosa modificare.

  7. #7
    User
    Data Registrazione
    Jun 2017
    Località
    Pianella
    Messaggi
    15
    Aggiungi henryco.88 su Facebook Aggiungi henryco.88 su Linkedin
    Mi dice sempre che la "connessione non è privata". In pratica riesco a vedere solamente il frontend (e neanche qui il backend) del sito internet tramite il browser Opera. Tutti gli altri browser mi restituiscono un errore di connessione privata.

    Dimmi cosa editare nel file configuration.php

  8. #8
    User L'avatar di altraSoluzione
    Data Registrazione
    Jun 2017
    Località
    Roma
    Messaggi
    42
    Segui altraSoluzione su Twitter Aggiungi altraSoluzione su Google+ Aggiungi altraSoluzione su Facebook Aggiungi altraSoluzione su Linkedin Visita il canale Youtube di altraSoluzione
    Cerca la linea
    Codice PHP:
     public $force_ssl 'x'
    e imposta x a 0.

    Poi, ovviamente, accedi al sito con http anziché https

    Comunque, se il problema è quello che penso io, sia su Firefox che su Chrome è possibile procedere al sito anche se la connessione non è privata, anche se il come farlo non è molto intuitivo. Su Opera non lo so.

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.