+ Rispondi alla Discussione
Risultati da 1 a 5 di 5

Problemi con le descrizioni su Google

Ultimo Messaggio di gianrudi il:
  1. #1
    User
    Data Registrazione
    Nov 2009
    Messaggi
    34

    Problemi con le descrizioni su Google

    Ciao ragazzi,
    ho notato tempo fa che alcune pagine del mio sito, indicizzate su Google, presentavano nella descrizione alcuni caratteri strani. Con il passare del tempo i vari caratteri accentati delle restanti pagine indicizzate sono stati sostituiti con quelli speciali.

    La codifica utilizzata la UTF-8 e non capisco come mai ogni carattere accentato visualizzato nella descrizione delle pagine del sito indicizzate sono mostrati male.

    Vorrei sistemare la faccenda, non digerisco quel tipo di caratteri.

    A cosa dovuta questa sostituzione? Come si pu risolvere?

    Grazie mille in anticipo

    P.S. provate a guardare facendo site:www . girandoilmondo . it

  2. #2
    Moderatore L'avatar di gianrudi
    Data Registrazione
    Apr 2008
    Localit
    ventimiglia
    Messaggi
    1,115
    Ciao GirandoilMondo,

    hai provato con le entit html, per esempio € invece del simbolo ?
    Ultima modifica di gianrudi; 22-10-10 alle 00:42

  3. #3
    User
    Data Registrazione
    Nov 2009
    Messaggi
    34
    Nelle pagine scritte in PHP ho sempre inserito è e compagnia, ed infatti la visualizzazione sulle pagine va bene, non ho nessun problema. Anche negli articoli, impostati da wordpress con codifica UTF-8 non ho problemi.

    Il problema si verifica solo ed esclusivamente nelle descrizioni degli articoli visualizzate su Google e non riesco a capire perch. Non mi era mai successo prima

  4. #4
    User
    Data Registrazione
    Nov 2009
    Messaggi
    34
    Forse ho trovato!!
    Tempo fa avevo impostato nell'header alcune righe:

    Codice:
    <meta name="DC.title" lang="it" content="Girando il Mondo" />
    <meta name="DC.creator" content="Giannotti Fabio" />
    <meta name="DC.subject" content="Voli,LowCost,Guide,Itinerari,Viaggi" />
    <meta name="DC.publisher" content="girandoilmondo.it" />
    <meta name="DC.language" scheme="DCTERMS. ISO639-2" content="it" />
    <meta name="DC.format" scheme="DCTERMS.IMT" content="text/html" />
    <meta name="DC.type" scheme="DCTERMS.DCMIType" content="Text" />
    Probabilmente a dare problemi ISO639-2. Fattibile? Ora l'ho rimosso....

  5. #5
    Moderatore L'avatar di gianrudi
    Data Registrazione
    Apr 2008
    Localit
    ventimiglia
    Messaggi
    1,115
    Mi sembra che il problema riguardi soprattutto il simbolo , e io nel sorgente della pagina non trovo &euro; ma .
    Ho provato a vedere altre pagine mie dove ho l'entit nelle descriptions e nel sorgente le vedo effettivamente come entit per esteso.

    Sei sicuro di avere le entit nelle descriptions per quanto riguarda l'euro?

    EDIT: ho inviato questa risposta prima di leggere il post che intanto stavi scrivendo tu, sul quale comunque non saprei dire, riguardo al metatag citato, se pu essere quello il problema. Fai qualche prova e facci sapere.
    Ultima modifica di gianrudi; 22-10-10 alle 01:05

+ Rispondi alla Discussione

Tag per Questa Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] Attivato
  • Il codice [VIDEO] Attivato
  • Il codice HTML Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.