+ Rispondi alla Discussione
Risultati da 1 a 11 di 11

2 strani errori di validazione w3c... "cannot continue because of previous errors"

Ultimo Messaggio di Maino il:
  1. #1
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88

    2 strani errori di validazione w3c... "cannot continue because of previous errors"

    Ciao, scusatemi ma sono un neofita in fatto di validazione w3c. Mi sono offerto di dare un contributo per il miglioramento dell'accessibilità di un forum dedicato alle scienze e tecnologie alimentari (taff.biz). Il sito è basato su una struttura completamente "autoprodotta" da miei amici e basata principalmente su php e mysql, con un ampio ricorso ai css per la formattazione.

    Come potete vedere sul sito ufficiale del w3c (appunto digitando taff.biz), il validatore individua 2 errori... E voi direte, sempre meglio 2 di 300 (come si legge in altri posts in questo forum).
    Certamente, se non fosse che il secondo errore è il seguente:


    Line 2, Column 64: cannot continue because of previous errors


    Che penso significhi che il bot non può proseguire la scansione a causa di questo errore... Quindi solstanzialmente non è che ci sono 2 errori, ma 2 sono quelli identificati fino alla seconda riga...

    Qualcuno riesce a darmi una mano? Non so che pesci pigliare.
    Il codice più lo ricontrollo e più mi sembra giusto.

    Grazie mille!
    Maino

  2. #2
    Moderatore
    Data Registrazione
    Oct 2009
    Messaggi
    1,279
    Hai avviato probabilmente lo strumento di validazione senza aver prima selezionato il tipo di codifica ed il tipo di documento della pagina che gli sottoponevi.

    Il tool ha bisogno del parametro per capire quali regole devi rispettare: avendo tu sbagliato la dichiarazione del tipo, non ha potuto che fermarsi.

    In questo frammento
    Codice:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" htt p://ww w.w3.org/TR/html4/loose.dtd>
    l'url va tra virgolette ("ww....loose.dtd").

    In alternativa puoi riavviare lo strumento scegliendo di passare direttamente tu i parametri attraverso i menù a tendina.

    Spero di esserti stato utile, in caso contrario posta ancora. Buona validazione!

  3. #3
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88

    Validazione: 126 errori, più una 30ina di avvisi..

    Ciao LaBussola,

    prima di tutto grazie mille per avermi risposto. Ho avuto dei problemi con il login su giorgiotave.it, ma adesso è tutto risolto.

    Nel weekend ho fatto le prove che mi hai consigliato (ho inserito i doppi apici) ed in effetti la scansione è andata a buon fine... Nel senso che la pagina è stata analizzata tutta. Il problema è che il validatore mi trovava 126 errori più una 30ina di avvisi (tutti improbabili, come ad esempio: i "?" presenti nei link dinamici, i "#" utilizzati per la generazione di tooltip, ecc).

    Inoltre ho notato oggi che l'inserimento del doctype genera un errore di lettura del CSS con IE (stano! )... Mi spiego: collegandosi al sito taff.biz tutte le etichette sopra i riquadri (ossia: argomenti, accedi, strumenti, ultime dichiarazioni, notizie, e così via) vengono visualizzate su IE8 delle dimensioni della scritta e non del riquadro sottostante.
    Ho fatto una prova e tutto viene risolto eliminando il doctype.

    Inizio seriamente a scoraggiarmi.. Forse adattare un sito agli standard w3c è un'impresa troppo difficile per me..

    Ringrazio fin d'ora chi vorrà aiutarmi.

    Un saluto a tutti!!!
    Maino

  4. #4
    ModSenior L'avatar di marcocarrieri
    Data Registrazione
    Jul 2009
    Località
    Rovigo
    Messaggi
    16,531
    Ciao Maino, se posso essere d'aiuto anche io, ho notato che alcuni link non hanno le virgolette.
    <a href=# invece dovrebbero essere href="#"

    Dai che l'unione fa la forsza.

  5. #5
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88

    120 Errors, 31 warning(s) = il php dà problemi di validazione!

    Citazione Originariamente Scritto da marcocarrieri Visualizza Messaggio
    Ciao Maino, se posso essere d'aiuto anche io, ho notato che alcuni link non hanno le virgolette.
    <a href=# invece dovrebbero essere href="#"

    Dai che l'unione fa la forsza.

    Ciao Marco e grazie anche a te per la risposta,

    ho seguito anche il tuo consiglio (ho inserito gli apici mancanti) e la situazione, seppur non di tanto, è migliorata... Da 136 errori più gli avvisi, ora siamo a 120 + 31 avvisi.

    Vedere per credere sul sito ufficiale w3c... Avrei voluto postarvi il link diretto, ma non avendo i privilegi di utente premium su giorgiotave.it non sono stato in grado. Dovrete quindi fare autonomamente

    L'URL da far validare è sempre quello: taff.biz

    Lo ripeto perchè magari, per la "briga" di leggere due post più sopra qualcuno potrebbe sorvolare...

    Comunque, leggendo le "motivazioni" del validatore w3c, sembra evidente che gli errori sono principalmente dovuti ai caratteri generati dal php per il contenuto dinamico delle pagine (es: &, ?, =, ecc.)

    In questa pagina ( htmlhelp.com/tools/validator/problems.html#amp ) suggerita dal validatore, viene consigliato di sostituire & con &amp; faccio qualche prova e poi vi faccio sapere.

    Intanto ragazzi, se avete dritte, postate... Quotando Marco: <<dai, ragazzi che insieme ce la possiam fare!>>

    Maino

  6. #6
    ModSenior L'avatar di marcocarrieri
    Data Registrazione
    Jul 2009
    Località
    Rovigo
    Messaggi
    16,531
    Ciao ho pensato a una cosa.
    Benchè se si ha l'idea di validare il sito, lo si dovrebbe fare per tutte le pagine, perchè non validare il sito ad esempio per la pagina "chi siamo", che ha meno contenuti?

    Una volta validata questa pagina, tutta la struttura (che spero utilizzi con degli include nelle altre pagine) dovrebbe essere validata, quindi nelle altre pagine, "dovrebbe" restare da validare solo il contenuto centrale della pagina, la parte variabile cioè.

    Spero di essermi spiegato bene.

  7. #7
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88

    Validator W3C: Almeno sui CSS ci siamo.

    Ciao Marco e ciao a tutti gli amici del forum!

    Come tu suggerivi, mi sono dedicato alla validazione di altre pagine di taff.biz. Nella fattispecie ho validato w3c tutti i fogli di stile (CSS) ed ora, almeno da questo punto di vista, posso ritenermi soddisfatto.

    Tuttavia, permane ancora un piccolissimo neo: il validatore w3c mi restituisce sempre 1errore ("opacity" non è un parametro CSS 2.1), quindi per vedere validato correttamente il sito, devo tutte le volte selezionare manualmente CSS3.

    Ora, la mia domanda è la seguente: esiste una sorta di dichiarazione (stile "doctype") che faccia capire al bot che versione di CSS sta per andare a leggere?

    Grazie mille!
    Maino

  8. #8
    ModSenior L'avatar di marcocarrieri
    Data Registrazione
    Jul 2009
    Località
    Rovigo
    Messaggi
    16,531
    Quel tipo di caratteristica è obbligatoria?
    O la si può tralasciare?

  9. #9
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88

    Validazione: quelle brutte "bestie" delle variabili php...

    Citazione Originariamente Scritto da marcocarrieri Visualizza Messaggio
    Quel tipo di caratteristica è obbligatoria?
    O la si può tralasciare?
    A dire il vero, se ti riferisci ad "opacity" non è vitale; anche perchè IE8 non se lo fila proprio...
    Comunque sia, non voglio andare OT, quindi direi di tornare al "core" (che può essere letto sia alla maniera anglofona sia a quella italica ) della discussione: come faccio a validare w3c questo benedetto forum??

    Sono fermo a 120 Errors, 31 warning(s). A proposito, ho fatto anche le prove con gli &amp; al posto degli & e volete sapere cosa succede? Vengo rediretto alla homepage... Per vedere di cosa parlo, immettete semplicemente nella barra degli indirizzi del vostro browser la pagina:

    taff.biz/index.php?frame=argomenti.php&argTopic=10

    e accederete ad un topic. Quindi sostituite "&" con "&amp;" ossia:

    taff.biz/index.php?frame=argomenti.php&amp;argTopic=10

    e vi ritroverete nella home...
    Forse sbaglio qualcosa... Qualche idea in proposito?



    Maino

  10. #10
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88

    Caso Studio W3C: da 120 a 4 errori

    Ciao a tutti!

    Nella speranza di fare qualcosa di utile anche per altri utenti del forum che si trovino in situazioni simili alla mia (decine e decine di errori, oltre a svariati warnings), torno in questo vecchio thread per aggiornarvi sull'andamento della validazione secondo lo standard w3c.

    Vi anticipo che non ho ancora risolto completamente (sono a 4 errori), ma chi lo sa... magari con il vostro prezioso contributo riuscirò a raggiungere finalmente l'ambito traguardo: 0 errors 0 warnings.

    Andando in ordine temporale:

    1) la prima cosa su cui è stato necessario intervenire è stato il doctype... E ringrazio LaBussola per il consiglio! Sembrerebbe una cosa da poco, ma il doctype è un pò la chiave di lettura per gli spiders; pertanto, un banale errore in tal senso (come i doppi apici nell'URL) può realmente compromettere l'intera validazione.

    2) parlando di "doppi apici", come giustamente mi fece notare marcocarrieri, è importante inserirli sempre dopo gli href..

    E qui aprirei una parentesi importante: mettendo mano a questi aspetti, vi renderete conto come questo tipo di errori generi a cascata altri errori.

    3) il mio doctype è impostato su "HTML 4.01 Transitional", mi sono reso conto che occorre prestare attenzione anche al codice che si incolla nella pagina... A cosa mi ridferisco? A tutti i tools proprietari (bottoni, search box, etc. ). Nel mio caso specifico, il Google search-box è codificato con una versione più recente di HTML (penso XHTML) pertanto prevede che ad esempio i tag <imput etc.> abbiano lo slash finale: <input etc. />

    Questa barretta del cappero mi ha fatto perdere un botto di tempo... Non riuscivo a capire da cosa dipendesse l'errore. Mi dicevo: <<la sintassi è corretta...>>

    Così mi guardavo e riguardavo il codice precedente, pensando si trattasse di un errore generato a cascata.

    4) altro punto importantissimo è stata la sintassi dei link... A quanto pare il w3c non apprezza particolarmente i link dinamici. Cosa intendo?

    Che, come accennavo nel mio post del 26-01-10, i link del tipo:

    taff.biz/index.php?frame=argomenti.php&argTopic=10

    non sono graditi. La soluzione è stata in questo caso ricorrere al Mod_rewite. E qui, apriti cielo!

    Ora mi ritrovo con i seguenti 4 errori:

    • 3 errori sono tag P di chiusura che, a detta del validatore non sono stati aperti, mentre visualizzando il codice noterete che i tag <p> ci sono eccome.
    • 1 errore è generato all'attributo dovuto all'incorporazione del player di YouTube. Questo attributo evidentemente non è supportato dal mio doctype.


    Avete qualche suggerimento in merito?

    Per ora non posso fare altro che ringraziarvi tutti per la pazienza e la disponibilità!
    Maino

  11. #11
    User L'avatar di Maino
    Data Registrazione
    Jan 2010
    Località
    Parma
    Messaggi
    88
    Ciao a tutti!

    A conclusione di quest'avventura (un lungo viaggio nei meandri più reconditi del w3c), torno ad aggiornarvi sugli ultimi sviluppi in tema di validazione.

    Il problema dei tag "p" è stato risolto con la loro rimozione... Mi rendo conto che è stata una soluzione piuttosto drastica, ma non sono riuscito a fare di meglio.

    Relativamente all'errore generato dall'inclusione del video youtube, il doctype da me utilizzato non consentiva il nuovo codice di incorporazione, pertanto ho dovuto sostituirlo con il vecchio, modificato opportunamente secondo le indicazioni di questo interessante articolo:

    toasa.net/2006/12/17/validare-in-w3c-il-codice-youtube/

    Se avete dubbi, sono qui.
    Maino

+ Rispondi alla Discussione

Tag per Questa Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.