+ Rispondi alla Discussione
Risultati da 1 a 3 di 3

Call to undefined function register field() a seguito di aggiornamento plug-in

Ultimo Messaggio di DarioMarco il:
  1. #1
    User
    Data Registrazione
    Dec 2007
    Messaggi
    333

    Call to undefined function register field() a seguito di aggiornamento plug-in

    Salve a tutti,
    mi sono appena loggato sull'admin di wp e ho visto che vi erano degli aggiornamenti dei plug-in, tra i quali advanced custom fields, ho provveduto ad aggiornare, ma purtroppo adesso ad ogni pagina di tutto il sito mi esce questo messaggio.
    Call to undefined function register field()
    ho letto nei vari post che bisogna o aggiornare o ripristinare, ma per evitare di peggiorare la situazione vorrei chiedere a voi cosa dovrei fare.
    Grazie, ciao.

  2. #2
    User L'avatar di AndMore
    Data Registrazione
    Jan 2012
    Localit
    Livorno
    Messaggi
    219
    Segui AndMore su Twitter Aggiungi AndMore su Google+ Aggiungi AndMore su Facebook Aggiungi AndMore su Linkedin Visita il canale Youtube di AndMore
    Ciao DarioMarco,

    veramente strana questa tua esperienza... Fammi capire una cosa, non che all'interno del tuo tema hai richiamato nelle pagine PHP la funzione register_field() da qualche parte? Perch, magari che questa mattina sono un p sfasato, ma non mi ricordo una funzione del genere all'interno del core WordPress...

    Quando ricevi un errore del genere significa che da qualche parte, all'interno del tuo tema o in qualche plugin, stai cercando di utilizzare una funzione che non mai stata dichiarata e quindi WordPress non sa cosa farsene. Prova a controllare il tuo codice e ad aggiornare il sito, magari riesci a trovare l'errore.

    Tienici aggiornati che siamo curiosi di capire meglio che cosa sta succedendo

    Andrea Barghigiani
    MOD WordPress
    SkillsAndMore - La scuola online per gli sviluppatori del futuro

  3. #3
    User
    Data Registrazione
    Dec 2007
    Messaggi
    333

    [risolto]

    Grazie per la risposta, a dire il vero non ho visto il codice e non so dirti, ma ad intuito, ho capito che come hai detto tu, c'erano parti del codice non dichiarati, e quindi causati da un aggiornamento sbagliato.
    Infatti come regola dovevo aggiornare prima il cms alla versione 3.5 e poi i plug-in, invece ho fatto il contrario.
    Ho risolto quindi facendo un aggiornamento manuale del cms.
    Grazie di nuovo del tuo interesse, se posso essere utile sono qui.

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] Attivato
  • Il codice [VIDEO] Attivato
  • Il codice HTML Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.