+ Rispondi alla Discussione
Risultati da 1 a 4 di 4

Backup e ripristino sito

Ultimo Messaggio di flaviors200 il:
  1. #1
    User
    Data Registrazione
    Jan 2019
    Località
    piemonte
    Messaggi
    30

    Backup e ripristino sito

    Ciao a tutti ho provato senza successo a salvare manualmente il mio sito per metterlo in locale con Xampp. La procedura è stata:

    - Salvataggio di tutti i files nel server
    - Esportazione database

    la procedura che volevo eseguire era:

    - Installare in locale una nuova copia di wordpress con un nuovo DB (in un secondo momento avrei caricato il mio tema)
    - Sostituire nel la stringa dell'indirizzo al mio sito w-w-wecc con localhost
    -Sostituzione del DB creato durante l'installazione da nuovo con quello che avevo nel sito

    Pensavo fosse tutto ok invece mi dice impossibile caricare localhost.

    Come mai? cosa c'e' di sbagliato?
    Grazie

  2. #2
    Utente Premium
    Data Registrazione
    Nov 2018
    Località
    Ragusa
    Messaggi
    250
    Aggiungi flaviors200 su Google+ Aggiungi flaviors200 su Facebook Aggiungi flaviors200 su Linkedin
    Ciao,

    che sistema operativo stai usando?

    Se usi Win, intanto verifica che il web server (Apache) sia avviato.

    Vai nella cartella di installazione di XAMPP

    C:\xampp

    tasto dx sull'eseguibile xampp-control.exe, quindi verifica dal pannello di controllo che il modulo Apache sia avviato (è evidenziato in verde).

    Se così non fosse forza l'avvio cliccando su "Start", se non riesce ad avviarsi controlla i log cliccando su "Logs" e error.log
    Sviluppo siti web dinamici e gestionali | Flaviobiscaldi.it

  3. #3
    User
    Data Registrazione
    Jan 2019
    Località
    piemonte
    Messaggi
    30
    Si è avviato come anche mysql.... Pero' ho notato che se non avvio Mysql mi dice Errore nello stabilire la connessione. Alchè ho pensato che se mi dice pagina non trovata la connessione col db la stabilisce.
    Ho provato copiando la cartella del tema e i contenuti li tira su ma non prende il css e quindi il layout. Inoltre se vado su wp-admin o in qualunque altro link o pagina del sito e mi dice oggetto non trovato.

    Ne deduco che da qualche parte nei file ci sia impostato il richiamo al tema di default ma non saprei dove.....

  4. #4
    Utente Premium
    Data Registrazione
    Nov 2018
    Località
    Ragusa
    Messaggi
    250
    Aggiungi flaviors200 su Google+ Aggiungi flaviors200 su Facebook Aggiungi flaviors200 su Linkedin
    Devi controllare i log sia di PHP che di MySQL. Senza quelle informazioni si possono fare solo supposizioni.

    Se non carica i css prova a dare un'occhiata alla console del browser.

    In Chrome Ctrl+Maiusc+C, tab "Console" verifica quali errori ti da. Inoltre nel DB ci saranno risorse col vecchio indirizzo, dovresti fare un replace se ancora non lo hai fatto.
    Sviluppo siti web dinamici e gestionali | Flaviobiscaldi.it

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.