+ Rispondi alla Discussione
Risultati da 1 a 3 di 3

attachSound che non funziona se caricato in un'altro flash

Ultimo Messaggio di simonah il:
  1. #1
    User Newbie L'avatar di simonah
    Data Registrazione
    Jan 2008
    Messaggi
    5

    attachSound che non funziona se caricato in un'altro flash

    buongiorno a tutti,
    ho un grosso problema con l'attachSound... allora ho tanti flash dove al loro interno hanno in libreria (ognuno ha i suoi) degli audio concatenati e gestiti con l'attachSound:

    var my_sound:Sound = new Sound();
    my_sound.attachSound("audio0");
    my_sound.onSoundComplete = audioFine;
    my_sound.start();


    se lancio i suddetti flash gli audio funzionano perfettamente e non danno problemi

    il problema nasce quando carico i suddetti flash all'interno di un'altro flash, non si sentono più e non sono più gestiti

    non posso caricare gli audio nel flash contenitore perchè gli audio nei vari flash hanno tutti i nomi uguali (ognuno ha audio0, audio1...)
    come posso risolvere questo problema? qualcuno si è trovato con il mio stesso problema?

    grazie a tutti

  2. #2
    User
    Data Registrazione
    May 2008
    Località
    Olbia
    Messaggi
    2,762
    Codice:
    var my_sound:Sound = new Sound(this)

  3. #3
    User Newbie L'avatar di simonah
    Data Registrazione
    Jan 2008
    Messaggi
    5
    Citazione Originariamente Scritto da Nhatan Visualizza Messaggio
    Codice:
    var my_sound:Sound = new Sound(this)

    grazie mille, Nhatan!!

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB è Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] è Attivato
  • Il codice [VIDEO] è Attivato
  • Il codice HTML è Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.