+ Rispondi alla Discussione
Risultati da 1 a 11 di 11

[Risolto] Men¨ spry e filmato FLASH

Ultimo Messaggio di Onsitus il:
  1. #1
    User
    Data Registrazione
    Aug 2007
    Messaggi
    50

    Men¨ spry e filmato FLASH

    Dopo aver penato settimane, per convertire il codice di tutte le pagine e renderlo compatibile per la validazione XHTML 1.0, mi si presenta questo ultimo ma fastidiosissimo problema!
    Mentre con tutti i browser (compreso firefox 2.0X) di win tutto ok, con FireFox 2.0X (ma anche 1.5) sotto linux (ho avuto modo di provare al momento ubuntu aggiornato) il men¨ principale ottenuto tramite spry di dreamweaver viene nascosto (quando espanso nei sottomen¨) sotto un filmato flash che si trova immediatamente a destra.

    Il problema Ŕ che per il momento non posso spostare ne il men¨ ne il filmato, e che anche se lo potessi fare dovrei farlo su tutte le pagine del sito!
    Non capisco come mai lo stesso prg sotto win funziona sotto linux rompe il bippp...

    Datemi una dritta per favore!

  2. #2
    User Attivo L'avatar di Flep
    Data Registrazione
    Feb 2006
    LocalitÓ
    Undisclosed city of South America
    Messaggi
    5,747
    Ciao,
    in questa sezione principalmente parliamo di problemi inerenti a Flash ed Actionscript. Credo che il tuo problema sia pi¨ di html o css ma credo che Onsitus possa aiutarti

  3. #3
    User
    Data Registrazione
    Aug 2007
    Messaggi
    50
    Citazione Originariamente Scritto da Flep Visualizza Messaggio
    Ciao,
    in questa sezione principalmente parliamo di problemi inerenti a Flash ed Actionscript. Credo che il tuo problema sia pi¨ di html o css ma credo che Onsitus possa aiutarti
    Flep intanto grazie per la risposta, sempre gradita anche se non risolutiva, ho postato qui il messaggio perchÚ pensavo che "l'anomalia" dipendesse da qualche settaggio di flash che potrebbe comunicare al flash player la profonditÓ Z del filmato.

    Onsitus in quale sez. lo trovo?

    2) ho anche un' altro problema con un altro filmato flash, in pratica quando caricato per la prima volta la pagina che lo contiene non compare il preload inserito nella scena precedente al filmato stesso, ma subito il primo fotogramma della scena successiva nella quale un gotoAndPlay(2); dovrebbe far saltare la testina di lettura al secondo fotogramma , invece anche dopo aver caricato tutto il filmato (ricordo senza mostrare il preloader) rimane tutto fermo al primo fotogramma della seconda scena
    se attivo uno dei pulsanti che spostano la testina al fotogramma successivo o precedente ottengo il caricamento del preloader e poi di ferma tutto lý. se aggiorno la pagina ricaricandola funziona tutto perfettamente, anche se ricarico la pagina le volte successive (fino che non viene svuotata la cache) il filmato si comporta correttamente!

    per capire il problema ecco l'indirizzo dove potrete provare quanto ho detto

    http://www.tiriolo.com/costume/costumescomposizione.htm

    Un saluto

  4. #4
    User
    Data Registrazione
    Aug 2007
    Messaggi
    50
    Citazione Originariamente Scritto da teradm Visualizza Messaggio
    2) ho anche un' altro problema con un altro filmato flash, in pratica quando caricato per la prima volta la pagina che lo contiene non compare il preload inserito nella scena precedente al filmato stesso, ma subito il primo fotogramma della scena successiva nella quale un gotoAndPlay(2); dovrebbe far saltare la testina di lettura al secondo fotogramma , invece anche dopo aver caricato tutto il filmato (ricordo senza mostrare il preloader) rimane tutto fermo al primo fotogramma della seconda scena
    se attivo uno dei pulsanti che spostano la testina al fotogramma successivo o precedente ottengo il caricamento del preloader e poi di ferma tutto lý. se aggiorno la pagina ricaricandola funziona tutto perfettamente, anche se ricarico la pagina le volte successive (fino che non viene svuotata la cache) il filmato si comporta correttamente!

    per capire il problema ecco l'indirizzo dove potrete provare quanto ho detto

    http://www.tiriolo.com/costume/costumescomposizione.htm

    Un saluto
    OK Questo Ŕ risolto!!! ho eliminato il primo fotogramma con il comando gotoAndPlay(2); ed cambiato l'action script per gestire il tutto senza e ora funge anche con linux

    Bye bye

  5. #5
    Esperta L'avatar di Onsitus
    Data Registrazione
    Oct 2006
    LocalitÓ
    RM
    Messaggi
    3,083
    Qui sono.

    Altro che con il z-index via CSS, puoi provare con il wmode transparent:
    http://kb.adobe.com/selfservice/view...5523&sliceId=1


  6. #6
    User
    Data Registrazione
    Aug 2007
    Messaggi
    50
    Citazione Originariamente Scritto da Onsitus Visualizza Messaggio
    Qui sono.

    Altro che con il z-index via CSS, puoi provare con il wmode transparent:
    http://kb.adobe.com/selfservice/view...5523&sliceId=1

    Onsitus, i miei filmati flash sono giÓ pubblicati con settato il wmode transparent, "<param name="wmode" value="transparent">questo perchÚ devono stare sopra a dei div con sfondi colorati-sfumati o immagini dove il filmato e "bucato" deve mostrare lo sfondo...
    Non posso per˛ settare la proprietÓ all'interno del tag embed perchÚ non Ŕ consentito usare tale tag all'interno delle pagine validate XHTML 1.0

    e poi il problema esce fuori solo con linux!
    per capire il problema prova ad espandere un men¨ dal sito: http://www.tiriolo.com/index.php
    poi riprovalo con linux...

  7. #7
    Esperta L'avatar di Onsitus
    Data Registrazione
    Oct 2006
    LocalitÓ
    RM
    Messaggi
    3,083
    Purtroppo non uso Linux.

    Sarebbe da cercare se ci sono qualche bug nella versione Firefox per Linux (succede). Per quello ti rimane il buon vecchio Google o trovarti un utente Linux in gamba che gia sa di quel problema.

    Riguardo, la validazione. So che puo essere importante ma ogni tanto se deve fare la scelta tra la giusta compatibilita e il buon funzionamento del sito.
    Comunque, cerchi piu info sul cosi detto 'Satay method' se puo esserti d'aiuto.
    Ultima modifica di Onsitus; 23-09-07 alle 20:59

  8. #8
    User
    Data Registrazione
    Aug 2007
    Messaggi
    50
    Citazione Originariamente Scritto da Onsitus Visualizza Messaggio
    Riguardo, la validazione. So che puo essere importante ma ogni tanto se deve fare la scelta tra la giusta compatibilita e il buon funzionamento del sito.
    Comunque, cerchi piu info sul cosi detto 'Satay method' se puo esserti d'aiuto.
    Ciao Onsitus, grazie come al solito per il reply, la validazione del sito in questo caso Ŕ abbastanza importante, e poi non convalidarlo per avere un problema di compatibilitÓ in meno non ha senso (senza la validazione prima il sito aveva una miriade di piccoli o grandi problemi di "compatibilitÓ")

    Per quanto riguarda il metodo Satay lo conosco, visto che proprio nella pagina specificata Ŕ adottato, altrimenti non avrei potuto validare la pagina con il filmato flash inserito e senza avere grossi problemi di usabilitÓ con IE (vedi entitÓ doppie visualizzate, etc..etc..), il metodo in pratica serve per aggirare la mancanza del tag embed necessario al buon funzionamento del flash player eseguito in IE, e prevede la costruzione di un filmato contenitore vuoto al quale passare come parametro il filmato originale.

    vedr˛ di stuzzicare un p˛ la comunitÓ di linux (strano un bug di FF su linux dal momento che quello ottimo su win Ŕ una importazione dell'originale per linux)

    bye bye

  9. #9
    Esperta L'avatar di Onsitus
    Data Registrazione
    Oct 2006
    LocalitÓ
    RM
    Messaggi
    3,083
    Citazione Originariamente Scritto da teradm Visualizza Messaggio
    vedr˛ di stuzzicare un p˛ la comunitÓ di linux (strano un bug di FF su linux dal momento che quello ottimo su win Ŕ una importazione dell'originale per linux)

    bye bye
    Bug del Flash Player per la versione Linux (da qualche parte un bug c'era - scusa l'ignoranza )

    Vedi un po questo:

    http://ubuntubible.wordpress.com/200...-ubuntu-linux/


  10. #10
    User
    Data Registrazione
    Aug 2007
    Messaggi
    50
    Citazione Originariamente Scritto da Onsitus Visualizza Messaggio
    Bug del Flash Player per la versione Linux (da qualche parte un bug c'era - scusa l'ignoranza )

    Vedi un po questo:

    http://ubuntubible.wordpress.com/200...-ubuntu-linux/

    Stavolta forse hai beccato il segno... sembra un problema del flashplayer v9 di linux che nasconde i men¨ di javascript mettendoli ad una profonditÓ inferiore al filmato flash!
    Posso provare ad adattare e convertire il filmato nella ver 8.0, vediamo se ho lo stesso problema, altrimenti alla diverse segnalazioni che mi pervengono far˛ presente del bug (giusto quasi per scolparmi) e col tempo vedr˛ di evitare evitare filmati sfash in prossimitÓ di men¨ javascript

    Di nuovo grazie e un saluto bye

  11. #11
    Esperta L'avatar di Onsitus
    Data Registrazione
    Oct 2006
    LocalitÓ
    RM
    Messaggi
    3,083
    Citazione Originariamente Scritto da teradm Visualizza Messaggio
    Stavolta forse hai beccato il segno... sembra un problema del flashplayer v9 di linux che nasconde i men¨ di javascript mettendoli ad una profonditÓ inferiore al filmato flash!
    Posso provare ad adattare e convertire il filmato nella ver 8.0, vediamo se ho lo stesso problema, altrimenti alla diverse segnalazioni che mi pervengono far˛ presente del bug (giusto quasi per scolparmi) e col tempo vedr˛ di evitare evitare filmati sfash in prossimitÓ di men¨ javascript

    Di nuovo grazie e un saluto bye
    Mentre cercavo su Google riferimenti su quel bug, ho ritrovato topic dal 2002. La Macormedia (Adobe) non sembra essere in fretta di risolvere quel problema per utenti Linux.

    Buon lavoro.

+ Rispondi alla Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB Ŕ Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] Ŕ Attivato
  • Il codice [VIDEO] Ŕ Attivato
  • Il codice HTML Ŕ Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.