+ Rispondi alla Discussione
Risultati da 1 a 13 di 13

Utente amministratore non ha pi i diritti

Ultimo Messaggio di Provatoo il:
  1. #1
    User Attivo L'avatar di Teju
    Data Registrazione
    Apr 2008
    Messaggi
    1,527

    Utente amministratore non ha pi i diritti

    Aiuto, ho un problema su uno dei siti WordPress che gestisco: l'utente amministratore non ha pi i permessi di accedere al pannello di amministrazione!
    Il sito su un server Windows, ed ultimamente stato sotto attacco molto, tanto che mi mandavano la CPU al 100% spessissimo, ma non sembrava avessero fatto danni visibili al sito, invece purtroppo qualcosa successo.

    Ho provato senza successo la procedura descritta in http(://)alessioangeloro.it/blog/guide-e-tutorial-wordpress/come-aggiungere-un-utente-wordpress-da-database-mysql/ per la creazione di un utente via SQL.

    Altre idee?
    Vieni a conoscermi sul mio blog personale: www.teju.it

  2. #2
    User L'avatar di Riccardo79
    Data Registrazione
    Aug 2013
    Localit
    Genova
    Messaggi
    101
    Segui Riccardo79 su Twitter Aggiungi Riccardo79 su Google+
    Se il solo utente amministratore un bel problema... Devi entrare nel database e resettargli manualmente la password (senza aggiungere un nuovo utente, a meno che non sia stato cancellato)

  3. #3
    Banned L'avatar di Provatoo
    Data Registrazione
    Jun 2009
    Localit
    Termoli
    Messaggi
    1,150
    Come suggerito da Riccardo, devi entrate da db e fare un aggiornamento, di sicuro il sito stato hackerato

  4. #4
    User Attivo L'avatar di Teju
    Data Registrazione
    Apr 2008
    Messaggi
    1,527
    Ma io accedo con utente e password, dunque non han cambiato la password, solo che quando provo ad accedere al wp-admin mi dice che non ho i diritti.
    Purtroppo ho pi account admin, ma tutti hanno lo stesso problema.
    Vieni a conoscermi sul mio blog personale: www.teju.it

  5. #5
    User L'avatar di Riccardo79
    Data Registrazione
    Aug 2013
    Localit
    Genova
    Messaggi
    101
    Segui Riccardo79 su Twitter Aggiungi Riccardo79 su Google+
    Se hai accesso al database, verifica che nella tabella wp_usermeta, alla riga "capabilities" ci sia scritto "a:1:{s:13:"administrator";b:1;}", o qualcosa del genere... e che la riga "user_level" contenga il valore 10 (anche se ormai questa riga deprecata).
    Occhio che nella tabella, di tali righe ve ne sono una per ogni utente registrato!

  6. #6
    User Attivo L'avatar di Teju
    Data Registrazione
    Apr 2008
    Messaggi
    1,527
    S, li contiene corretti, ma continua l'errore "You do not have sufficient permissions to access this page" accedendo al WP-admin...

    Ma se io reinstallo un WP da zero, con utenti nuovi, carico plugin e template, e recupero solamente la tabella wp_posts mediante SQL, cosa perdo? Le features images dove sono?
    Non vedo molte altre soluzioni mi sa...!
    Vieni a conoscermi sul mio blog personale: www.teju.it

  7. #7
    Banned L'avatar di Provatoo
    Data Registrazione
    Jun 2009
    Localit
    Termoli
    Messaggi
    1,150
    ah ecco hai wp su windows...ora mi spiego mooolte cose. potrebbe esser colpa di windows

  8. #8
    User Attivo L'avatar di Teju
    Data Registrazione
    Apr 2008
    Messaggi
    1,527
    No, non ho Windows, un hosting condiviso su DremHost.
    Reinstallo WP = WordPress ;-)
    Vieni a conoscermi sul mio blog personale: www.teju.it

  9. #9
    User L'avatar di Riccardo79
    Data Registrazione
    Aug 2013
    Localit
    Genova
    Messaggi
    101
    Segui Riccardo79 su Twitter Aggiungi Riccardo79 su Google+
    Non che c' qualche riga sbagliata nell'htaccess?
    O i permessi sbagliati in wp-admin? Dovrebbero essere 755, mi pare...
    Prima di reinstallare tutto sarebbe bene fare qualche altro controllo, magari anche contattando l'assistenza tecnica dell'hosting.
    Ultima modifica di Riccardo79; 12-05-16 alle 12:54

  10. #10
    User Attivo L'avatar di Teju
    Data Registrazione
    Apr 2008
    Messaggi
    1,527
    755 le directory, 644 i file...
    Provo a scrivere al provider, anche se non nutro grandi speranze. Grazie mille!
    Vieni a conoscermi sul mio blog personale: www.teju.it

  11. #11
    Banned L'avatar di Provatoo
    Data Registrazione
    Jun 2009
    Localit
    Termoli
    Messaggi
    1,150
    penso che sia un problema dell'hosting se nemmeno il tempo di installarlo te lo hackerano! tienici aggiornato

  12. #12
    User Attivo L'avatar di Teju
    Data Registrazione
    Apr 2008
    Messaggi
    1,527
    Citazione Originariamente Scritto da Provatoo Visualizza Messaggio
    penso che sia un problema dell'hosting se nemmeno il tempo di installarlo te lo hackerano! tienici aggiornato
    ?? Ha retto 4 anni senza problemi...!
    Comunque risolto ricostruendomi in locale il sito e recuperando dal database post e pagine.
    Vieni a conoscermi sul mio blog personale: www.teju.it

  13. #13
    Banned L'avatar di Provatoo
    Data Registrazione
    Jun 2009
    Localit
    Termoli
    Messaggi
    1,150
    allora te lo hanno hackerato...importante recuperare!

+ Rispondi alla Discussione

Tag per Questa Discussione

^ Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
  • Il codice BB Attivato
  • Le faccine sono Attivato
  • Il codice [IMG] Attivato
  • Il codice [VIDEO] Attivato
  • Il codice HTML Disattivato
  • Trackbacks Attivato
  • Pingback Attivato
  • Refback Attivato

SEO by vBSEO 3.6.0 PL2 ©2011, Crawlability, Inc.